Messages récents

Pages: 1 [2] 3 4 ... 10
11
Le réseau / Configurer un NAT Statique sous Cisco (IOS 15.1)
« Dernier message par OnKleBen le septembre 03, 2018, 02:21:24 pm »
Le NAT statique permet de traduire une IP en une autre à travers un routeur. Cela peut-être utile par exemple pour accéder à un serveur qui est dans un réseau local par le biais d'une IP publique.

On va voir ici la création basique d'une règle NAT statique sur un routeur Cisco 1941.


-------------------------------------


Admettons la petite topologie suivante :


-Une topologie grandement simplifiée et peu réaliste mais qui peut permettre de comprendre certaines choses.


-Vous pouvez télécharger le fichier Packet Tracer histoire de faire vos propres simulations de requêtes et ainsi vous assurer que les IP sont bien traduites :

Télécharger le fichier Packet Tracer
-------------------------------------


Le but principal est que le PC Client puisse accéder au Serveur grâce à l'adresse 64.100.25.3. Il est important de comprendre qu'en réalité, aucune interface ne possède explicitement cette adresse IP !

Quand Client va envoyer une requête vers 64.100.25.3, la requête va passer par la passerelle par défaut 172.16.0.1 puisqu'elle va chercher à changer de réseau, et à ce moment là, le routeur remarquera que l'IP de destination est 64.100.25.3. Le routeur comprendra alors qu'il doit acheminer ce paquet vers l'IP 192.168.0.10, grâce à une règle que l'on va configurer.

On va donc expliquer à R1 comment il doit réagir lorsqu'il reçoit une requête à destination de 60.100.25.3.


-------------------------------------


Sur R1 :


->Je pars du principe que les interfaces de R1 possèdent déjà la configuration visible sur le schéma. Je n'ai donc plus qu'à paramétrer ma règle de NAT.


R1(config)#ip nat inside source static 192.168.0.10 64.100.25.3 : La première IP est l'ip locale et la deuxième est l'IP globale. L'ip locale est simplement la vraie IP du serveur, celle qui est compatible avec son réseau local et qui est configurée sur sa propre interface. L'IP globale est en gros l'IP à laquelle vous souhaitez voir votre serveur accessible depuis le réseau externe.


->Ensuite on va spécifier sur G0/0 et G0/1, que ces interfaces entrent en jeu dans notre règle de NAT. On va indiquer à G0/0 qu'elle fait partie du réseau interne, et à G0/1 qu'elle fait partie du réseau externe.


->Pour G0/0 :


R1(config)#interface g0/0 : on se place dans la configuration de l'interface...

R1(config-if)#ip nat inside : on indique que l'interface est interne vis-à-vis du NAT.


->Puis pour G0/1 :


R1(config)#interface g0/1

R1(config-if)#ip nat outside : on indique que l'interface est externe vis-à-vis du NAT.


-------------------------------------


-Pour vérifier la configuration effectuée :

R1#show ip nat translations


-------------------------------------


-Pour afficher des statiques sur les translations effectuées par le routeur :

R1#show ip nat statistics


-Pour remettre les statistiques à zéro :

R1#clear ip nat statistics


-------------------------------------


A partir de là Client peut pinguer l'adresse globale du Serveur 64.100.25.3.


------------------------------------------------------------

12
Le réseau / Configurer RIPv2 sur routeur Cisco IOS 15.1
« Dernier message par OnKleBen le août 29, 2018, 12:21:20 pm »
Voici comment configurer RIPv2 (Routing Information Protocol) sur un routeur Cisco. Il s'agit d'un exemple simple qui aborde les quelques commandes pour activer le protocole RIPv2 et ainsi automatiser la mise à jour des tables de routage des différents routeurs d'un réseau.


---------------------------


Prenons cette topologie basique :




-->Vous pouvez téléecharger le fichier Packet Tracer si vous voulez !

Télécharger le fichier Packet Tracer


Dans ce réseau plus que basique, l'idéal serait vraiment de rentrer des routes statiques au lieu de configurer RIP mais peu importe, la mise en œuvre sera la même si le réseau est plus développé.

-Dans ce petit exemple, R1 et R2 ne possèdent pas de route statique, donc PC1 et PC2 ne peuvent pas communiquer puisqu'ils sont sur différents réseaux.

-On va activer RIPv2.

-On va désactiver la récapitulation de réseau (obligatoire si vous avez des sous-réseaux).

-On va dire à R1 de transmettre l'information RIP suivante : pour atteindre le réseau 1, il faut passer par lui.

-On va ensuite dire à R2 de transmettre l'information RIP suivante : pour atteindre le réseau 3, il faut passer par lui.

-On va ensuite dire à R1 et R2 que le réseau 2 est atteignable par chacun d'eux. Malgré que R1 et R2 soient directement connectés au réseau 2, RIP nécessite cette information.

-Une fois les informations transmises d'un routeur à l'autre, leurs tables de routage seront mises à jour et les PC seront capable de communiquer.


---------------------------


D'abord une commande pour afficher les éventuels protocoles de routage actifs sur le routeur.


R1#show ip protocols


->La réponse à cette commande peut varier en fonction de votre configuration en cours. Si RIP est déjà activé la commande affichera :

Routing Protocol is "rip"


---------------------------


Sur R1 :


R1(config)#router rip : active RIP et entre dans le mode de configuration router.

R1(config-router)#version 2 : pour activer RIPv2.

R1(config-router)#no auto-summary : cette commande désactive la récapitulation de réseau, ainsi les adresses de réseau ne seront pas traitées par classe. Par exemple, un sous réseau 172.16.10.0/24 sera enregistré comme tel et sans cette commande, il serait enregistré sous la forme 172.16.0.0/16, ce qui peut poser des problèmes.

R1(config-router)#network 10.0.0.0 : ajoute une donnée RIP à propos du réseau 1, qui sera transmise à R2.

R1(config-router)#network 223.255.255.252 : ajoute une donnée RIP à propos du réseau 2, qui sera transmise à R2 également.


->R1 va donc informer l'autre routeur qu'il est directement connecté aux réseaux 10.0.0.0 et 223.255.255.252.


---------------------------


Sur R2 :


R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 192.168.0.0 : ajoute une donnée concernant le réseau 3, qui sera transmise à R1.

R2(config-router)#network 223.255.255.252 : ajoute une donnée RIP à propos du réseau 2, qui sera transmise à R1 également.


->R2 va donc informer l'autre routeur qu'il est directement connecté aux réseaux 192.168.0.0 et 223.255.255.252.


---------------------------


En somme il s'agit donc d'entrer ces commandes dans chaque routeur du réseau, en spécifiant seulement les IP des réseaux qui sont directement connectés. Cette information sera alors transmise de routeur en routeur et les tables de routage seront mises à jour automatiquement.


->Les PC1 et PC2 peuvent maintenant se pinguer.


---------------------------


Si le routeur possède une route par défaut (passerelle de dernier recours), il est intéressant de dire à RIP de transmettre également cette information, afin que les autres routeurs sachent également où trouver cette route.


R1(config)#router rip

R1(config-router)#default-information originate


---------------------------


Une commande qui permet de changer la distance administrative pour RIP au niveau d'un routeur, afin que, si nécessaire, le chemin choisi par RIP soit prioritaire sur un chemin choisi par EIGRP. Cela peut être utile dans des cas bien spécifique où RIP et EIGRP sont actifs sur le routeur mais qu'on veut y privilégier RIP pour diverses raisons.


R1(config)#router rip

R1(config-router)#distance 89 : le nombre 89 ne dépend que de votre souhait bien sûr, ici le chiffre 89 rendra prioritaire RIP sur EIGRP puisque par défaut ce dernier a une distance administrative de 90.


---------------------------


Une autre commande qui permet de désactiver les mises à jour sur une interface donnée. Par exemple si une interface est reliée à un switch qui lui-même n'est relié qu'à des PC, il n'y a pas d'utilité à envoyer une mise à jour par cette interface, et aucune n'y sera jamais reçue non plus. C'est donc mieux de désactiver la mise à jour sur cette interface.


R1(config)#router rip

R1(config-router)#passive-interface f0/1 : désactive les mises à jour par le biais de l'interface f0/1.


------------------------------------------------------------

13
La vie / Re : Faire des économie sur l'essence avec le superéthanol
« Dernier message par daniel le août 28, 2018, 01:31:27 am »
14
Le streaming / Re : Regarder simplement du Streaming sans limite de temps.
« Dernier message par daniel le août 28, 2018, 01:29:51 am »
ce site y a aucun pubs c le meilleur streaming vf
15
Le streaming / Re : Regarder simplement du Streaming sans limite de temps.
« Dernier message par streamiz le août 27, 2018, 09:35:53 pm »
pour 2018 je trouve très beau site de streaming de film c'est https://streamiz-hd.xyz une version hd avec une designe de ouff
16
Le réseau / Routage inter-vlan "existant" sous Cisco
« Dernier message par OnKleBen le août 27, 2018, 03:54:36 pm »
Le routage inter-vlan dit "existant" consiste à utiliser une interface physique du routeur pour chaque VLAN. A contrario du routage de type Router-On-A-Stick ( comme on a vu ici : http://www.infotrucs.fr/le-reseau/routage-inter-vlan-sous-cisco/ ) qui permet d'utiliser des interfaces virtuelles du routeur.

Dans cette méthode il n'y a pas besoin de port Trunk non plus.

---------------------------


Admettons la topologie suivante :



*Vous pouvez télécharger le fichier Packet Tracer si vous le souhaitez :

Télécharger le fichier Packet Tracer


->Soit deux vlans qui seront reçus puis routés par le routeur par deux de ses interfaces.

-->Remarquez l'adresse de la passerelle par défaut des deux PC qui correspond aux interfaces respectives du routeur.

----------------------------


-Création des vlans sur S1 :


S1(config)#vlan 10 : Créer le vlan 10.

S1(config-vlan)#vlan 20 : Créer le vlan 20.


S1(config-vlan)#interface range f0/1-f0/2 : pour configurer f0/1 et f0/2 en même temps.

S1(config-if-range)#switchport mode access : pour activer l’accès vlan sur ces ports.

S1(config-if-range)#switchport access vlan 10 : pour assigner ces ports au vlan 10.


S1(config-if-range)#interface range f0/5-f0/6 : pour configurer f0/5 et f0/6 en même temps.

S1(config-if-range)#switchport mode access

S1(config-if-range)#switchport access vlan 20 : les assigner au vlan 20.


->C'est tout pour le switch, on passe au routeur.

----------------------------


-Affectation d'adresses IP aux interfaces du routeur :


R1(config)#interface g0/0 : sélectionne l'interface g0/0.

R1(config-if)#ip address 192.168.10.254 255.255.255.0 : on donne une IP et un masque à l'interface.

R1(config-if)#no shutdown : on active l'interface.


R1(config-if)#interface g0/1 : on sélectionne l'interface g0/1.

R1(config-if)#ip address 192.168.20.254 255.255.255.0 : on lui attribue IP et masque.

R1(config-if)#no shutdown : et on l'active


-->Notez que les IP que l'on donne à ces interfaces sont sur le même réseau que les PC du vlan respectif.

-----------------------------


--> Les PC peuvent maintenant se pinguer.


------------------------------------------------------------



17
Le réseau / Créer une route statique sur routeur Cisco
« Dernier message par OnKleBen le août 27, 2018, 11:48:12 am »
Un exemple simple de configuration de route statique sur routeur Cisco 1941.

Dans cet exemple, les interfaces sont déjà configurées, seules les routes statiques sur R1 et R2 manquent afin que les deux réseaux 192.168.0.0/24 et 192.168.1.0/24 puissent communiquer.



-Téléechargez le fichier Packet Tracer si vous le souhaitez :

Télécharger le fichier Packet Tracer


->Notez la passerelle par défaut de PC1 et PC2 qui correspond à l'IP de l'interface du routeur sur laquelle chacun est connecté.

Ajoutons à R1 et R2 des routes statiques afin que les réseaux vert et jaune puissent communiquer entre eux.

---------------------------

-Sur R1 :

R1(config)#ip route 192.168.1.0 255.255.255.0 10.0.0.2

->On crée une route pour attendre le réseau 192.168.1.0 avec son masque 255.255.255.0, et on spécifie que pour atteindre ce réseau on passera par l'interface de R2 qui possède l'IP 10.0.0.2.

Une route est créée mais seulement dans un sens. Pour que, par exemple, un ping de PC1 vers PC2 puisque revenir, il faut également ajouter une route sur R2.

---------------------------

-Sur R2 :

R1(config)#ip route 192.168.0.0 255.255.255.0 10.0.0.1

->On indique donc à R2 que pour atteindre le réseau 192.168.0.0 dont le masque est 255.255.255.0, il doit passer par l'interface de R1 qui possède l'IP 10.0.0.1.

---------------------------

-Pour être sûr de notre coup, affichons la table de routage de R1 et R2 :

-Sur R1 :

R1#show ip route

Dans la table de routage, vous devriez retrouver votre réseau 192.168.1.0 :

S    192.168.1.0/24 [1/0] via 10.0.0.2

---------------------------

-Sur R2 :

R2#show ip route

->Devrait vous afficher la table comprenant :

S    192.168.0.0/24 [1/0] via 10.0.0.1

---------------------------

La manœuvre est terminée, les PC1 et PC2 doivent pouvoir se pinguer.

------------------------------------------------------------

18
Le réseau / Routage inter vlan sous Cisco (Router On A Stick)
« Dernier message par OnKleBen le août 27, 2018, 09:32:06 am »
On va voir ici comment router 2 vlans sur des équipements Cisco, en utilisant une seule interface du routeur, et des interfaces virtuelles (des sous-interfaces). C'est la méthode Router-On-A-Stick. Cette méthode est limité par la création de 50 sous-interfaces maximum par interface physique.

Nous utiliserons :

-2 PC, chacun dans un vlan différent.

-Un switch sur lequel sont connectés les 2 PC, avec 2 vlans configurés.

-Un routeur, sur lequel est connecté le port trunk du switch.

------------------------------------


Nous n'aborderons pas ici la création des vlans et du trunk, sujets qui sont abordés ici :

http://www.infotrucs.fr/le-reseau/configuration-basique-de-vlan-cisco-ios-12-2/

La manipulation sera donc très simple et nous n'interviendrons que sur le routeur.

------------------------------------


On va se baser sur ce schéma simple :



-->Vous pouvez télécharger le fichier Packet Tracer si vous le souhaitez :

Télécharger le fichier Packet Tracer


Tout les informations nécessaires pour comprendre la topologie sont inscrites sur l'image. Ici on va donc simplement créer les interfaces virtuelles (ou sous-interface) g0/0.1 et g0/0.2 sur l'interface g0/0 du routeur, leur assigner des IP compatibles avec chacun des 2 vlans, et activer le protocole 802.1Q sur chacune d'elles.


-->A noter que :

-La passerelle par défaut de PC1 est 192.168.10.1

-La passerelle par défaut de PC2 est 192.168.20.1

...qui sont les IP respectives des interfaces virtuelles du routeur.

------------------------------------


On prend donc la main sur le routeur, puis :

R1(config)#interface g0/0.1 : crée l'interface virtuelle g0/0.1 puis entre dans sa configuration.

R1(config-subif)#encapsulation dot1Q 10 : on active le protocole 802.1q sur cette interface, précisant qu'elle écoute le vlan 10.

R1(config-subif)#ip addr 192.168.10.1 255.255.255.0 : on assigne une IP et Masque compatible avec le vlan 10.

-->La première sous-interface est configurée. On va maintenant faire la même chose sur la deuxième.

--->Faites bien l'encapsulation AVANT d'assigner une IP.

------------------------------------


R1(config)#interface g0/0.2 : crée la deuxième interface virtuelle g0/0.2 puis entre dans sa configuration.

R1(config-subif)#encapsulation dot1Q 20 : et on active le protocole 802.1q sur cette interface aussi, précisant qu'elle écoute cette fois le vlan 20.

R1(config-subif)#ip addr 192.168.20.1 255.255.255.0 : on assigne une IP et Masque compatible avec le vlan 20 cette fois.

------------------------------------

->Vos 2 vlans peuvent maintenant se pinguer !

------------------------------------------------------------


19
La vie / Re : Faire des économie sur l'essence avec le superéthanol
« Dernier message par OnKleBen le août 14, 2018, 10:13:46 am »
Petite update !

Bon alors depuis un bon moment maintenant je ne mets que 30% de E85 dans titine car il faut bien dire qu'en en mettant plus, ça se ressent dans la nervosité qui est amoindrie.

Aucun problème n'est survenu, si vous n'êtes pas un puriste de la mécanique, cela reste une bonne petite économie :)

N'exagérez pas dans vos tests, moi j'y suis allé un peu fort en mettant 100% au début ! Même si rien n'a cassé, vaut mieux pas tenter le diable, allez-y doucement !!

JE RAJOUTE QUE JE NE SUIS EN RIEN RESPONSABLE DES RESULTATS DE VOS PROPRES EXPERIENCES ET SI UN PROBLEME SURVIENT VOUS NE POUVEZ VOUS EN PRENDRE QU'A VOUS ! ALLEZ-Y MOLLO AVEC VOTRE TITE BAGNOLE !
20
Le réseau / Configurer server http sur matériel Cisco IOS 15.2
« Dernier message par OnKleBen le août 03, 2018, 10:07:21 am »
Testé sur routeur Cisco 1941.

Pour activer l'interface graphique par navigateur, executer ces commandes :


R1(config)#ip http server

R1(config)#ip http secure-server

R1(config)#ip http authentication local : pour utiliser les identifiants locaux.

R1(config)#username admin privilege 15 secret adminpass1 : l'identifiant admin avec le mot de passe adminpass1 seront demandés lors de l'accès.



------------------------------------------------------------

Pages: 1 [2] 3 4 ... 10