26 mars 2019

TUTO Configurer Samba 4 AD sous Debian 9

Gestion d’utilisateurs

On va d’abord créer un nouvel admin du domaine puis désactiver le compte administrator pour des raisons de sécurité.

-Allez dans Menu Windows / Outils d’administration / Utilisateurs et ordinateurs Active Directory.

-Développez le conteneur Users puis faites un clique-droit dans le cadre et Nouveau / Utilisateur :

-Renseignez les infos utilisateur et choisissez l’identifiant de connexion puis Suivant :

-Entrez un mot de passe complexe, attention aux options aussi, puis Suivant :

->Cliquez sur Terminer.

-Maintenant double-cliquez sur l’utilisateur fraichement créé puis allez dans l’onglet Membre de. Cliquez sur Ajouter et tapez Domain admins puis validez et enfin Appliquer :

->L’utilisateur est maintenant Admin du domaine. C’était bien de voir ça, au moins pour constater que le nom du groupe est différent par rapport à un AD Windows.

-On va maintenant créer un groupe pour tester un peu après une GPO qui agira dessus. Faites un clique droit puis Nouveau / Groupe :

-Simulons le service Direction d’une entreprise :

->C’est bon pour ça, on s’en servira tout à l’heure pour tester une GPO.

-Maintenant on désactive le compte administrator. Faites un clique-droit sur l’utilisateur administrator puis Désactiver le compte :

->Déconnectez votre session Windows puis identifiez vous avec le nouvel admin du domaine.

On va tester une GPO à la page suivante.

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18

You may also like...

6 Responses

  1. mikedafunk dit :

    Merci pour cette documentation !

  2. vincent dit :

    Salut!

    qq trucs, pourquoi modifie-tu le krb5.conf généré par samba?
    la team samba recommande ne ne rien ajouter 🙂
    tu y met des paramètres inutiles, par exemple kdc_timesync = 1 et ccache_type = 4, c’est déjà les valeurs par défaut.
    de plus c’est des paramètres valables uniquement pour un kerberos MIT, alors qu’un peu plus bas tu a fcc-mit-ticketflags, un paramètre qui lui n’est valable que pour un kerberos HEIMDAL.

    coté windows 10, inutile de régler le serveur de temps (sauf si poste vraiment pas a l’heure), lors de la jonction au domaine windows se cale automatiquement sur le serveur AD/SAMBA pour se mettre a l’heure.
    a-tu vérifié si tes clients se mettent bien a l’heure après jonction au domaine? car le serveur de temps que tu rentre avant la jonction doit être remplacé automatiquement lors de la jonction, mais par défaut windows utilise NT5DS, or ton ntp.conf n’est pas configuré pour utiliser NT5DS (il manque l’option ntpsigndsocket et mssntp)

    et dernier truc, tu ajoute une zone dns inverse, mais elle ne sera pas remplie par tes clients windows si tu ne met pas « allow dns updates = nonsecure » dans le smb.conf.

    sinon bon tuto 🙂

    • ben dit :

      Honnetement je ne sais plus vraiment pourquoi ceci ou cela lol ça fait un moment que j’ai potassé le sujet. Je garde ton commentaire sous le coude tu as l’air bien calé sur le sujet et le jour où j’aurais besoin de me repencher sur la question il me servira. A tout hasard est-ce que je peux te contacter par mail un de ces 4 ? Si c’est la bonne adresse que je vois ici ?

  3. vincent dit :

    oui pas de soucis, le mail est le bon 🙂
    « calé sur le sujet » je sais pas, mais comme j’ai du ré-installer un samba AD sur une debian 10 dernièrement mes souvenirs sont frais!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *