14 octobre 2018

Configuration basique de vlan Cisco IOS 12.2

Quelques commandes basiques pour mettre en place des vlan sur des switch cisco, avec configuration de ports trunk pour la transmission des vlan entre plusieurs switchs, ou vers un routeur.

->Le routage de vlans n’est pas abordé ici.

-Voir le routage inter-vlans ROAS : www.infotrucs.fr/le-reseau/routage-inter-vlan-sous-cisco/
-Voir le routage inter-vlans par interface : www.infotrucs.fr/le-reseau/routage-inter-vlan-'existant'-sous-cisco/

Ces commandes sont testées sur des switchs virtuels Cisco WS-C2960-24TT, sous Packet Tracer.

————————————

Afficher les informations de configuration déjà existante :

switch#show vlan brief : affiche les vlan existants et les port affectés. En configuration d’usine tous les ports sont dans le vlan 1.

switch#show vlan id 20 : affiche des infos sur le vlan 20. Son nom, son type, les ports attribués..

switch#show vlan name xxxx : affiche les infos du vlan nommé xxxx.

switch#show interfaces vlan 20 : affiche d’autres infos sur le vlan 20.

switch#show interfaces f0/1 switchport : affiche les informations de vlan concernant le port f0/1.

switch#show interface trunk : affiche les trunks configurés.

————————————

Créer un vlan :

 

S1(config)#vlan 20 : Créer le vlan 20. Si le vlan 20 existe déjà, cette commande permettra d’entrer dans sa configuration.

–Supprimer un vlan :

S1(config)#no vlan 20 : supprime le vlan 20.

————————————

Donner un nom à un vlan existant :

 

–On entre d’abord dans la configuration du vlan 20 :

S1(config)#vlan 20 : Attention si le vlan 20 n’existe pas il sera créé avec cette commande.

S1(config-vlan)#name etudiants : le vlan 20 possède maintenant le nom etudiant.

————————————

Donner une ip à un vlan :

 

S1(config)#interface vlan 20 : Entre dans la configuration de l’interface du vlan.

S1(config-if)#ip address 192.168.0.20 255.255.255.0 : Donne une ip et un masque à cette interface.

————————————

Attribuer des ports à un vlan :

 

–Pour attribuer un port on entre d’abord dans la configuration du port :

S1(config)#interface f0/20 : entre dans la config du port FastEthernet0/20.

S1(config-if)#switchport mode access : défini que le port servira à accéder à un vlan.

S1(config-if)#switchport access vlan 20 : place le port dans le vlan 20. Si le vlan 20 n’avait pas été créé auparavant, cette commande aurait également créé le vlan 20, ce qui peut éviter une manip.

–On peut facilement mettre le port dans un autre vlan avec la même commande, toujours dans la configuration de l’interface f0/20 :

S1(config-if)#switchport access vlan 30 : l’interface n’est plus dans le vlan 20 mais dans le vlan 30.

–On peut bien sûr sortir le port du vlan. Toujours dans la configuration de l’interface f0/20 :

S1(config-if)#no switchport access vlan

 

–Attribuer une plage de ports à un vlan :

S1(config)#interface range f0/1-f0/20 : entre dans la configuration des ports de f0/1 à f0/20.

S1(config-if-range)#switchport mode access : pour établir que ces ports auront un accès à un vlan (comme vu plus haut).

S1(config-if-range)#switchport access vlan 20 : les ports de f0/1 à f0/20 sont maintenant dans le vlan 20.

*On ne peut attribuer qu’un seul vlan par port. Seul dans le cas unique où un vlan VoIP doit passer par ce port, le port pourra avoir un vlan de données plus le vlan VoIP, donc 2 vlan.

————————————

Configurer des ports trunk pour la transmission des vlans entre switchs (ou vers un routeur) :

 

Un petit exemple en image permettra de mieux recadrer le contexte.

On a deux vlans sur le réseau. Sur S1 et S2, on va configurer les deux vlans et attribuer les ports f0/11 et f0/18 à leurs vlans respectifs.

Sur S3 on va créer les deux vlans sans leur attribuer de ports.

Sur S1, S2, et S3, on va passer en mode trunk les ports qui relient les switchs.

On créera également un vlan natif sur les trois switchs, et attribuer les ports trunk à ce vlan natif.

Penser à ajouter un nom de domaine aux trois switchs.

On verra ici comment passer un seul port en mode trunk. La manipulation étant identique pour chaque port à trunker.

-Configuration de S1, interface f0/1 :

 

S1(config)#vlan 99 : crée le vlan 99 qui servira de vlan natif aux ports trunk. Le vlan natif sert de « poubelle » pour les trames non taguées (qui n’appartiennent à aucun vlan) qui pourraient entrer par le port trunk.

S1(config)#interface f0/1 : entre dans la configuration du port f0/1.

S1(config-if)#switchport mode trunk : passe l’interface en mode trunk. L’interface redémarre.

S1(config-if)#switchport trunk native vlan 99 : attribue le vlan 99 comme vlan natif pour ce port. Vous aurez un message d’erreur à ce moment, tant que vous n’aurez pas défini le port f0/1 du switch S3 également sur le vlan natif 99. Le vlan natif sert de « poubelle » pour les trames non taguées (qui n’appartiennent à aucun vlan) qui pourraient entrer par le port trunk.

S1(config-if)#switchport trunk allowed vlan 10,20 : grâce à cette commande, seuls les vlan 10 et 20 sont autorisés à passer par ce port trunk. Sans cette commande, tous les numéros de vlans sont autorisés, ce qui est moins sécurisé.

-Supprimer les vlans autorisés sur ce trunk :

 

S1(config-if)#no switchport trunk allowed vlan : supprime les vlans antérieurement autorisés.

-Supprimer le vlan natif de ce trunk :

 

S1(config-if)#no switchport trunk native vlan

-Recommencer l’opération sur les autres switchs en adaptant les noms des interfaces bien sûr (vous pouvez voir sur l’image quels ports doivent être en trunk).

————————————–

*Pensez à sauvegarder la configuration de chaque switch sinon au prochain démarrage tout sera perdu :

S1#write

 

You may also like...

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *