22 janvier 2019

Configurer OSPF sur routeur Cisco

Exemple 1 – 2 areas, sans route par défaut

Plages des sous-réseaux (SR6 n’est pas encore présent)

Vous pouvez télécharger le fichier Packet Tracer déjà configuré ici (PT 7.2) : www.infotrucs.fr/divers/ospf-no-gw.pkt

Lancez la commande show run sur les routeurs pour afficher la configuration en cours

Les commandes :

R0 – Internal

R0(config)# int g0/0/0
R0(config-if)# ip addr 172.16.0.1 255.255.255.192

R0(config-if)# int s0/1/0
R0(config-if)# ip addr 172.16.1.1 255.255.255.252

R0(config)# router ospf 1
-> On active OSPF. 1 représente le numero du processus OSPF.
R0(config-router)# network 172.16.0.0 0.0.0.63 area 0
-> On indique SR0 qui est directement connecté, en précisant qu’on le veut dans l’area 0.
R0(config-router)# network 172.16.1.0 0.0.0.3 area 0
->On indique SR4 de la même façon.

R1 – Internal

R1(config)# int g0/0/0
R1(config-if)# ip addr 172.16.0.65 255.255.255.192

R1(config)# int s0/1/1
R1(config-if)# ip addr 172.16.1.5 255.255.255.252
R1(config-if)# ip ospf priority 20
-> On élit ce routeur comme DR, le suivant sera BDR avec la priorité 10.

R1(config-if)# int s0/1/0
R1(config-if)# ip addr 172.16.1.2 255.255.255.252
R1(config-if)# ip ospf priority 20
-> Même principe pour la priorité. Constatez aussi qu’on la défini sur chaque interface connectée à un routeur.

R1(config)# router ospf 1
R1(config-router)# network 172.16.1.0 0.0.0.3 area 0
->Pour SR4.
R1(config-router)# network 172.16.1.4 0.0.0.3 area 0
->Pour SR5.
R1(config-router)# network 172.16.0.64 0.0.0.63 area 0
->Pour SR1.

R2 – ABR

R2(config)# router ospf 1
R2(config-router)# network 172.16.0.128 0.0.0.63 area 1
-> Pour mettre SR2 en Area 1.
R2(config-router)# network 172.16.0.192 0.0.0.63 area 1
-> Pour mettre SR3 en Area 1.
R2(config-router)# network 172.16.1.4 0.0.0.3 area 0
Pour mettre SR5 sur area 0.

R2(config-if)# int s0/1/1
R2(config-if)# ip address 172.16.1.6 255.255.255.252
R2(config-if)# ip ospf priority 10
-> Ce routeur devient donc BDR puisque R1 a une priorité plus haute à 20.
R2(config-if)# ip ospf 1 area 0

R2(config)# int g0/0/0
R2(config-if)# ip address 172.16.0.129 255.255.255.192
R2(config-if)# ip ospf 1 area 1
>Dans le cadre d’un routeur ABR on doit définir quelle interface est dans quelle area.

R2(config-if)# int g0/0/1
R2(config-if)# ip address 172.16.0.193 255.255.255.192
R2(config-if)# ip ospf 1 area 1

Vous avez maintenant un beau routage dynamique fonctionnel.

Tables de routage

Explorons la table de routage de R0 :

R0# show ip route

*Les routes commençant par la lettre O sont reçues via OSPF. La mention IA signifie InterArea, en effet, ce sont des réseaux qui sont en Area 1.

Voyons aussi la table de routage de R1 :
Et la table de R2 :

On va voir en page suivante comment ajouter une passerelle par défaut (default route) pour sortir sur Internet.

Pages: 1 2 3

You may also like...

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *