22 janvier 2019

Configurer OSPF sur routeur Cisco

Exemple 2 – Ajout de route par défaut

L’exemple 2 est donc une suite de l’exemple 1. On va voir comment simplement ajouter une passerelle par défaut pour sortir sur Internet.

Le schéma a donc un peu changé :

Un nouveau routeur R3 est ajouté.
Seule la configuration de R2 a changé depuis.
Je vais donc détailler la configuration de R2 en la reprenant depuis le début, puis détailler la configuration de R3.

Vous pouvez télécharger le fichier Packet Tracer déjà configuré ici (PT 7.2) : www.infotrucs.fr/divers/ospf-gw.pkt

Les commandes :

R2

R2(config)# router ospf 1
R2(config-router)# network 172.16.0.128 0.0.0.63 area 1
R2(config-router)# network 172.16.0.192 0.0.0.63 area 1
R2(config-router)# network 172.16.1.4 0.0.0.3 area 0
**Configuration ajoutée**
R2(config-router)# network 172.16.1.8 0.0.0.3 area 0
**Fin de la configuration ajoutée**

R2(config-if)# int s0/1/1
R2(config-if)# ip address 172.16.1.6 255.255.255.252
R2(config-if)# ip ospf priority 10
R2(config-if)# ip ospf 1 area 0

**Configuration ajoutée**
R2(config-if)# int s0/1/0
R2(config-if)# ip address 172.16.1.9 255.255.255.252
R2(config-if)# ip ospf priority 10
->Cette interface est reliée à un voisin, on défini donc de nouveau la priorité OSPF.
R2(config-if)# ip ospf 1 area 0
**Fin de la configuration ajoutée*

R2(config)# int g0/0/0
R2(config-if)# ip address 172.16.0.129 255.255.255.192
R2(config-if)# ip ospf 1 area 1

R2(config-if)# int g0/0/1
R2(config-if)# ip address 172.16.0.193 255.255.255.192
R2(config-if)# ip ospf 1 area 1

R3 – ASBR et Gateway

*Cette interface n’est là que pour simuler un réseau externe (Internet)
R3(config)# int g0/0/0
R3(config-if)# ip addr 1.0.0.1 255.0.0.0
*Notez que cette interface étant à l’extérieur, on ne la lie à aucune area.

R3(config-if)# int s0/1/0
R3(config-if)# ip addr 172.16.1.10 255.255.255.252
R3(config-if)# ip ospf 1 area 0

R3(config-if)# router ospf 1
R3(config-router)# 172.16.1.8 0.0.0.3 area 0
R3(config-router)# default-information originate
*Cette commande indique à OSPF de transmettre la route par défaut que l’on va créé juste après.

R3(config-router)# exit
R3(config)# ip route 0.0.0.0 0.0.0.0 g0/0/0
*Et on indique la route par défaut en pointant l’interface externe g0/0/0.

Table de routage de R2 :
Table de routage de R3 :

Conclusion

C’est la fin de cet article qui pose les bases du protocole OSPF. Bien sûr il y a quelques autres subtilités mais selon moi l’essentiel est là. Si vous êtes arrivé au bout je vous dis chapeau, surtout si vous ne connaissiez pas avant, car c’est pas une mince affaire. Cela dit, après avoir potassé cet article vous devriez être en mesure d’implémenter un routage dynamique OSPF au sein de votre infrastructure, et ça, c’est quand même sympa !

Si vous constatez une coquille, je vous serais très reconnaissant de me laisser un petit commentaire svp 🙂

Merci d’avoir lu et à bientôt !


Pages: 1 2 3

You may also like...

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *