26 mars 2019

TUTO Configurer Samba 4 AD sous Debian 9

Intégrer le client au domaine

On intègre maintenant le Windows 10 dans le domaine infotrucs.lan.

Je suppose que vous connaissez déjà la procédure mais je détaille au cas où.

-Sous Windows 10, tapez WindowsKey + Pause pour ouvrir les propriétés systèmes. Ensuite cliquez sur Modifier les paramètres :

-Dans la fenêtre qui s’ouvre, cliquez sur Modifier :

-Cochez ensuite Domaine puis entrez votre nom de domaine et cliquez Ok :

-Entrez alors les identifiants d’admin du domaine, soit administrator / P@ssword01, puis Ok :

-Votre client est alors admis dans le domaine :

Victoire ! Vous pouvez redémarrer Windows 10.

A la page suivante, on va loguer avec administrator et tester le DNS.

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18

You may also like...

6 Responses

  1. mikedafunk dit :

    Merci pour cette documentation !

  2. vincent dit :

    Salut!

    qq trucs, pourquoi modifie-tu le krb5.conf généré par samba?
    la team samba recommande ne ne rien ajouter 🙂
    tu y met des paramètres inutiles, par exemple kdc_timesync = 1 et ccache_type = 4, c’est déjà les valeurs par défaut.
    de plus c’est des paramètres valables uniquement pour un kerberos MIT, alors qu’un peu plus bas tu a fcc-mit-ticketflags, un paramètre qui lui n’est valable que pour un kerberos HEIMDAL.

    coté windows 10, inutile de régler le serveur de temps (sauf si poste vraiment pas a l’heure), lors de la jonction au domaine windows se cale automatiquement sur le serveur AD/SAMBA pour se mettre a l’heure.
    a-tu vérifié si tes clients se mettent bien a l’heure après jonction au domaine? car le serveur de temps que tu rentre avant la jonction doit être remplacé automatiquement lors de la jonction, mais par défaut windows utilise NT5DS, or ton ntp.conf n’est pas configuré pour utiliser NT5DS (il manque l’option ntpsigndsocket et mssntp)

    et dernier truc, tu ajoute une zone dns inverse, mais elle ne sera pas remplie par tes clients windows si tu ne met pas « allow dns updates = nonsecure » dans le smb.conf.

    sinon bon tuto 🙂

    • ben dit :

      Honnetement je ne sais plus vraiment pourquoi ceci ou cela lol ça fait un moment que j’ai potassé le sujet. Je garde ton commentaire sous le coude tu as l’air bien calé sur le sujet et le jour où j’aurais besoin de me repencher sur la question il me servira. A tout hasard est-ce que je peux te contacter par mail un de ces 4 ? Si c’est la bonne adresse que je vois ici ?

  3. vincent dit :

    oui pas de soucis, le mail est le bon 🙂
    « calé sur le sujet » je sais pas, mais comme j’ai du ré-installer un samba AD sur une debian 10 dernièrement mes souvenirs sont frais!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *